Author Archives: Adrian Kielbowicz

Lenovo ThinkServer System Manager defult username and password

Lenovo_Server_Logo

Lenovo ThinkServer System Manager default username and password are as follows:

Username: Lenovo
Password: len0vO

Both username and a password are case sensitive. Please notice there is a zero ‘0’ and letter O in word len0vO..

Took me a while to work it out but there you have it!

vCenter Multi-Hypervisor Manager connection fails with “A problem occurred while connecting to the vCenter Multi-Hypervisor Manager service. The server fault ‘NoPermission’ had no message.”

VMware_vSphere_Logo

I thought that it would be a good idea to finally install vCenter Multi-Hypervisor Manager to manage my 3rd party hosts i.e. Hyper-V – at least that was the initial idea anyway since I don’t have enough time to mess around with SCVMM for now. Multi-Hypervisor Manager server installation was pretty straight forward and so was the client. With plugin enabled in vSphere C# client I was able to see the relevant icon in my client:

vCenter_Multi-Hypervisor_Manager_fails_with_A_problem_occurred_while_connecting_to_the_vCenter_Multi-Hypervisor_Manager_service_The_server_fault_NoPermission_had_no_message_4

but the next screen was not so pretty:

vCenter_Multi-Hypervisor_Manager_fails_with_A_problem_occurred_while_connecting_to_the_vCenter_Multi-Hypervisor_Manager_service_The_server_fault_NoPermission_had_no_message_1

Basically ‘NoPermission’ but I can access vCenter server just fine since I have all the relevant rights! It turns out Multi-Hypervisor Manager assigns the default ‘Admin’ role only to the user specified during the installation of MHM and no one else. During the installation of MHM you have to specify the account that will be made administrator of the third-party hosts inventory:

Continue reading

Virtual machine customisation fails with error “A specified parameter was not correct. spec.identity.userData.computerName”.

VMware_vSphere_Logo

Today I was testing some new Windows Server 2012 templates and noticed something rather odd. Basically my costomisations would cause the deployments from template to fail for no real reason. Error message that came up was:

Virtual_machine_customisation_fails_with_error_A_specified_parameter_was_not_correct._spec.identity.userData.computerName_1

Continue reading

Cancelling stuck VMware Tools install on vSphere 5.5

VMware_vSphere_Logo

(Not so) happy Monday morning!

First request of the day – one of the VM’s was unresponsive and had to be rebooted (RDP was hanging and no incoming connections were allowed). I’m thinking not a big deal so VM was rebooted but I have noticed that VMware Tools were not up to date so thought why not update them at the same time? This is where it all started to go wrong… At this point VM was not responding (which I knew about) AND VMware Tools install was totally stuck on some random percentage in Recent Tasks. Great start.

Few things I have tried before finding the proper solution:

  • Trying to cancel the install by right clicking on Initiated VMware Tools Install or Upgrade in Recent Tasks didn’t yield any results. Option was greyed out.
  • Powering off the VM was unsuccessful as well. Again, options to Power Off, Reset etc. were greyed out.
  • Ejecting the .iso file that’s responsible for VMware Tools install didn’t help since the .iso was not connected.
  • Continue reading

    VMware vSphere 5 virtual machine thin provisioned disk size greyed out!

    VMware_vSphere_Logo

    Here’s something rather interesting. I was about to increase size of thin provisioned disk on one of my VM’s and was greeted with my usual option (as expected) being greyed out (not so expected!) I certainly haven’t seen that before. Picture for illustration purposes showing what I’m on about:

    VMware_virtual_machine_thin_provisioned_disk_size_greyed_out!_1

    I’m thinking since there is -000001.vmdk file present I must be running off a snapshot that prevents me from resizing the disk (which would make sense..) Another picture showing Snapshot Manager window:

    Continue reading

    How to deploy Barracuda Malware Removal Tool aka Malwarebytes?

    Barracuda_Logo

    In previous parts of my deployment how to’s I talked about deploying 7-Zip 9.20 and VLC Media Player 2.0.4 so if you haven’t seen that yet go and check it out.

    In today’s post I wanted to share my deployment scripts for Barracuda Malware Removal Tool also known as re-skinned version of Malwarebytes. Barracuda Malware Removal Tool is part of Barracuda Web Filter Vx family of appliances so its a really good idea to take advantage of the software and deploy it out in your organisation.

    First script is the Install.bat script which takes care of:

  • Adding EventViewer entry at the start/end of the deployment
  • Removing previous versions of Barracuda Malware Removal Tool or Malwarebytes’ Anti-Malware
  • Deploying Barracuda Malware Removal Tool 1.46 (change the .exe name as appropriate)
  • Silently updating database definitions
  • Note: You can push the script below to x86 as well as x64 architectures.

    Continue reading

    Creating a host profile from an ESXi host results in “argument of type NoneType is not iterable” error message.

    VMware_vSphere_Logo

    Here’s an interesting one – all of a sudden my hosts started showing as “Unknown” on Host Profile Compliance screen. Error message that I was presented with reads as – “Unexpected error checking compliance: argument of type NoneType is not iterable”. Screenshot to complete the picture:

    Creating_a_host_profile_from_an_ESXi_host_results_in_argument_of_type_NoneType_is_not_iterable_error_message_2

    Trying to create a new host profile from the affected host was not successful either with similar error message:

    Creating_a_host_profile_from_an_ESXi_host_results_in_argument_of_type_NoneType_is_not_iterable_error_message_1
    Continue reading

    NetApp Virtual Storage Console 5.0 displays “Unable to add storage systems due to insufficient privileges.”

    NetApp_Logo

    Last week I have installed VMware vSphere 5.5 on my test host and today was the time to get the NetApp Virtual Storage Console 5.0 going so I could take advantage of Rapid Cloning and other good stuff that VSC 5.0 includes.

    Installation was straight forward (recommended read – Virtual Storage Console 5.0 for VMware® vSphere® – Installation and Administration Guide) and next logical step was to add my Storage Systems so I could provision datastores etc. From within VSC section in vSphere Web Client I was trying to add new Storage System just to be presented with the following:

    “Unable to add storage systems due to insufficient privileges. You do not have sufficient permission to perform this action on: the root object. Contact your administrator to add the following mission privileges: Add, Modify, and Skip storage systems”

    NetApp_Virtual_Storage_Console_5.0_displays_Unable_to_add_storage_systems_due_to_insufficient_privileges_1
    Continue reading

    How to downgrade VMware ESXi 5.1 virtual machine hardware to version 7 (from 8)

    VMware_vSphere_Logo

    So here we are, lovely Thursday morning at work and requirement for new VM comes up – I’m thinking not a big deal since I have deployed thousands of VMs before but there is a catch this time (there always is!) All of my Windows Server templates are virtual machine HW version 8 and I need to deploy one server to ESXi 4.1 host – great! ESXi 4.1 uses HW version 7 at the most so HW version 8 will not work – if you attempt to add HW version 8 to the inventory on ESXi 4.1 host you will be met by the following outcome:

    VM adds fine and without any errors but its grayed out and with invalid status. Not much you can do here apart from removing it from the inventory.

    How_to_downgrade_VMware_ESXi_5.1_virtual_machine_hardware_to_version_7_1

    Continue reading

    Installation of .NET 3.5 fails on Windows 8 with Error Code 0x800F0906

    Windows_8_Logo

    You would have thought that installing .NET 3.5 on Windows 8 will be relatively straight forward – wrong answer!

    The easiest way to do this is to go to Control Panel –> All Control Panel Items –> Programs and Features and simply add .NET Framework 3.5 (includes .NET 2.0 and 3.0)

    Installation_of_.NET_3.5_fails_on_Windows_8_with_Error_Code_0x800F0906_1

    but you are likely to hit one of the following errors:

    “Windows couldn’t complete the requested changes. Windows couldn’t connect to the internet to download necessary files. Make sure that you’re connected to the internet, and click ‘Retry’ to try again. Error code: 0x800F0906”

    “Update NetFx3 of package Microsoft .NET Framework 3.0 failed to be turned on. Status: 0x800F0906.”

    “Update NetFx3 of package Microsoft .NET Framework 3.0 failed to be turned on. Status: 0x800F081F.”

    “Update NetFx3 of package Microsoft .NET Framework 3.0 failed to be turned on. Status: 0x800F0907.”
    Continue reading