NetApp VSC 5 breaks after updating VMware vCenter to 5.5 update 3b

NetApp_Logo

More SSLv3 (Poodle vulnerability) woes as this time NetApp VSC 5.0 is broken!

So my vCenter 5.5 update 2a got updated to update 3e without much of a problem but SRM and VSC are busted now. Great. Virtual Storage Console sort of works but the backup jobs tab hasn’t got any entries and you cannot re-create them due to the following errors:

NetApp_VSC_5_breaks_after_updating_VMware_vCenter_to_5.5_Update_3b_1

Rest of the VSC console works as expected i.e. you can see the storage systems and perform the usual tasks just backups and restores are not working. To resolve this connectivity problem on the VSC servers you need to edit two configuration files, these are:

%ProgramFiles%\Netapp\Virtual Storage Console\smvi\server\etc\wrapper.conf

and

%ProgramFiles%\Netapp\Virtual Storage Console\wrapper\wrapper.conf

First file needs additional line adding in position 5 under Java Additional Parameters effectively enabling TLS v1, 1.1 and 1.2:

NetApp_VSC_5_breaks_after_updating_VMware_vCenter_to_5.5_Update_3b_2

Second file needs the same line too but in position 8:

NetApp_VSC_5_breaks_after_updating_VMware_vCenter_to_5.5_Update_3b_3

Once done a reboot of the server VSC is running on is all that’s required to have the backup/restore tabs working!

NetApp_VSC_5_breaks_after_updating_VMware_vCenter_to_5.5_Update_3b_4

One thought on “NetApp VSC 5 breaks after updating VMware vCenter to 5.5 update 3b

Leave a Reply